Jump to content

Viewing problems while playing Rebellion.


Recommended Posts

Not sure if anyone else has had this problem.


I'm running Rebellion on Windows XP Home on a 1024x768 32-bit resolution. Never had a problem with it until Tuesday evening. After doing a little readjusting character attributes with RebEd, I launched the game. I had all the sound of the introduction, but no visual. Even when I got to the menu, I had the music, but no cockpit or background. Just a black screen.


Thinking maybe it was just a lapse in the resolution switch, I tried the standard Esc, Space Bar, and Enter tricks. Got nothing. I hit the Windows key, and my desktop came back up.


The only problem was the right side was on the left, and the left was on the right, and there was a three-inch black bar running down the center of it. It proceeded to blink like a strobe light until I turned the monitor off and turned it back on. Then it was fine. A few more experiments with this brought the same result.


Then today, it finally worked. I got into the game and was able to see everything. But whenever I click on a message icon, I receive the "Rebellion has performed an illegal operation..." window and the game shuts down, oftentimes reverting my monitor to its ridiculous inside-out state.


Anyone have any suggestions as to what the problem is? My first guess is the monitor's pretty much shot, or at least needs to be readjusted in some way. I've switched down to 800x600 and had the same results. Even went to the properties menu of Rebellion itself and selected the "Run in 256 color mode" and 640x480 resolution boxes. Still the same result.


And to boot, sometimes it switches halfway. I get everything on half the screen, right in the middle with a giant translucent white box over it. The sides of the screen are black, but the bottom portion of the center plays the game animations, while that milky sheen covers it and the top half of the center of the screen.


I've also reinstalled the game, uninstalled and installed it (losing a pair of games in the process) and partial-installed a few things from RebEd itself. Nothing's worked so far.


Time to get a new monitor? Or is there some trick for me to find up my sleeve with a little help?

Link to comment
Share on other sites

I use Rebellion and RebEd on XP home myself and have never had any problems (Knock on wood). I wish I could think of something, but this has me stumped. Hopefully some of the other old hands will have some idea.-Grand Moff Conway
Link to comment
Share on other sites

  • SWR Staff - Executive
Tried changing compatibility mode? Or could be an incompatibility with the video drivers or DirectX? Usually I'd say to upgrade to the latest versions of those software, but given the age of Rebellion, it is possible that there won't be support for the game in more current software.


http://swrebellion.com/images/banners/rebellionbanner02or6.gif Webmaster

http://swrebellion.com/images/banners/swcicuserbar.png Administrator


Fighting is terrible, but not as terrible as losing the will to fight.

- SW:Rebellion Network - Evaders Squadron Coding -

The cake is a lie.

Link to comment
Share on other sites

Everything's been updated recently. And it's all worked fine through updates and everything. It just decided, apparently, to stop working.


I copied the game's data onto a CD-R disc, thinking maybe the CD just finally burned itself out. No dice there, either.


Looks like I'm going to have to just buy a power supply for my old CPU and try to work that back into effectiveness somehow. Windows ME...shiver.


Thanks for the attempts at help, though. It's probably all just some stoopid mistake I made while fiddling around with the DLL entries or something.


Of course, then, it would've worked after I uninstalled it and reinstalled it completely...hmm...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Copyright (c) 1999-2022 by SWRebellion Community - All logos and trademarks in this site are property of their respective owner. The comments are property of their posters. Star Wars(TM) is a registered trademark of LucasFilm, Ltd. We are not affiliated with LucasFilm or Walt Disney. This is a fan site and online gaming community (non-profit). Powered by Invision Community

  • Create New...